Print Articles Issue

Incident Report for PressReader

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 09:19 PST

Update

The printing issues have been resolved.
Posted Jan 27, 2026 - 09:18 PST

Investigating

Please be advised we are experiencing technical issues for the following services that relate multiple products/sites on our network.

- Currently not possible to print articles from the website on Pressreader.com and Branded Edition sites

We are currently working on the issues and will provide an update as soon as possible.


PressReader Technical Team
Posted Jan 27, 2026 - 04:11 PST
This incident affected: Branded Editions (Web sites) and PressReader (PressReader.com).