Errors loading PressReader.com and Editions+

Incident Report for PressReader

Resolved

The issue with PressReader.com and Editions+ has now been resolved.
Posted Sep 23, 2026 - 00:48 PDT

Monitoring

A fix has been implemented and we are monitoring the progress.
Posted Sep 23, 2026 - 00:40 PDT

Investigating

We are investigating errors affecting PressReader.com and Editions+. Readers may be unable to load pages. We are working to restore normal service.
Posted Sep 22, 2026 - 23:41 PDT
This incident affected: Editions + (Web sites) and PressReader (PressReader.com).