TECHNICAL STATUS

Incident Report for PressReader

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 17:24 PST

Investigating

Please be advised we are experiencing some technical issues for the following services that relate multiple products/sites on our network.
- XML features on some titles may have a slight delay.

We are currently working on the issues and will provide an update as soon as possible.
Posted Nov 24, 2025 - 15:09 PST
This incident affected: Content Processing and Delivery (Content Delivery).