This incident has now been resolved as of 18:10 PST, and all impacted services have been restored to normal operation. We will continue to closely monitor system performance to ensure sustained stability. Thank you for your patience and understanding.
Posted Mar 24, 2026 - 18:32 PDT
Update
Some services are already fixed. Our engineers are continuing on fixing the issue.
Posted Mar 24, 2026 - 17:38 PDT
Update
Our engineers are continuing to fix the issue.
Posted Mar 24, 2026 - 16:21 PDT
Update
We are continuing to fix the issue.
Posted Mar 24, 2026 - 15:09 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 24, 2026 - 13:49 PDT
Investigating
Please be advised that we are currently experiencing an internal technical issue that is affecting our entire platform. We are currently working on this as a high priority and will provide updates as they become available.
Posted Mar 24, 2026 - 13:20 PDT
This incident affected: Editions + (Apps, Web sites), Content Processing and Delivery (Content Processing, Content Delivery), PressReader (Apps, PressReader.com), Partner Tools (Rich Media Tool (RMT), Business Analytics), and Public API.